netbsd man page for optstr_get

Query: optstr_get

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

OPTSTR(9)						   BSD Kernel Developer's Manual						 OPTSTR(9)

NAME
optstr_get -- Options string management
SYNOPSIS
#include <sys/optstr.h> bool optstr_get(const char *optstr, const char *key, char *buf, size_t bufsize);
DESCRIPTION
An options string is a list of key/value pairs represented in textual form. Each pair is expressed as ''key=value'' and is separated from other pairs by one or more spaces. For example: key1=value1 key2=value2 key3=value3 Options strings are used to pass information between userland programs and the kernel in a binary-agnostic way. This makes them endianness and ABI independent.
FUNCTIONS
The following functions are provided to manage options strings: optstr_get(optstr, key, buf, bufsize) Scans the optstr options string looking for the key key and stores its value in the buffer pointed to by buf copying a maximum of bufsize bytes. Returns 'true' if the key was found or 'false' otherwise, in which case buf is left unmodified.
CODE REFERENCES
The options string management functions are implemented within the files sys/kern/subr_optstr.c and sys/sys/optstr.h.
HISTORY
Options strings appeared in NetBSD 4.0.
BSD
August 11, 2007 BSD
Related Man Pages
hash(9) - netbsd
prop_dictionary_get_cstring_nocopy(3) - netbsd
hash32_buf(9) - netbsd
getfsstat(2) - freebsd
chdb_create(3) - php
Similar Topics in the Unix Linux Community
sorting left-justified numeric values
How to install PGX32 on Sparc 10 Ultra?
Better to Use Return Code or wc -l Output?
NetBSD 6.1.2: apm and admd not found
Grep command to show the number of results