netbsd man page for memcmp

Query: memcmp

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

MEMCMP(9)						   BSD Kernel Developer's Manual						 MEMCMP(9)

NAME
memcmp -- compare byte string
SYNOPSIS
#include <sys/systm.h> int memcmp(const void *b1, const void *b2, size_t len);
DESCRIPTION
The memcmp() function compares byte string b1 against byte string b2. Both strings are assumed to be len bytes long.
RETURN VALUES
The memcmp() function returns zero if the two strings are identical, otherwise returns the difference between the first two differing bytes (treated as unsigned char values, so that '200' is greater than '', for example). Zero-length strings are always identical.
STANDARDS
The memcmp() function conforms to ANSI X3.159-1989 (``ANSI C89'').
BSD
July 7, 2001 BSD
Related Man Pages
memcmp(3) - debian
memcmp(3) - suse
strncmp(3) - netbsd
memcmp(3) - v7
memcmp(3) - xfree86
Similar Topics in the Unix Linux Community
Help in memcmp (it may be a bug)