netbsd man page for lwp_cache_creds

Query: lwp_cache_creds

OS: netbsd

Section: 9

Links: netbsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

LWP_CACHE_CREDS(9)					   BSD Kernel Developer's Manual					LWP_CACHE_CREDS(9)

NAME
LWP_CACHE_CREDS -- synchronize LWP credential with process credential
SYNOPSIS
#include <sys/lwp.h> void LWP_CACHE_CREDS(lwp_t *l, struct proc *p);
DESCRIPTION
LWP_CACHE_CREDS() updates the LWP's cached credential to match with the process' credential if the latter has been changed after the last synchronization. Each LWPs have its cached credential so that it can be used without worrying about potential of other LWP changing the process' credential. kauth_cred_get() returns the cached credential. LWP_CACHE_CREDS() is called by MD entry code for system call and various traps. LWPs which can live in kernel for long period should call LWP_CACHE_CREDS() by itsself to refresh its credential. LWP_CACHE_CREDS() takes the following arguments. l The calling lwp. p The process which the lwp l belongs to. LWP_CACHE_CREDS() might be implemented as a macro.
SEE ALSO
intro(9), kauth(9)
BSD
December 9, 2007 BSD
Related Man Pages
crget(9) - debian
crhold(9) - debian
cru2x(9) - debian
_lwp_kill(2) - netbsd
ucred(3perl) - opensolaris
Similar Topics in the Unix Linux Community
sorting left-justified numeric values
Vm versus physical linux server
Adding a List of Times
Grep command to show the number of results