netbsd man page for imin

Query: imin

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

IMAX(9) 						   BSD Kernel Developer's Manual						   IMAX(9)

NAME
imax, imin, lmax, lmin, max, min, ulmax, ulmin -- compare integers
SYNOPSIS
int imax(int a, int b); int imin(int a, int b); long lmax(long a, long b); long lmin(long a, long b); u_int max(u_int a, u_int b); u_int min(u_int a, u_int b); u_long ulmax(u_long a, u_long b); u_long ulmin(u_long a, u_long b);
DESCRIPTION
The imin(), lmin(), min(), and ulmin() functions return whichever argument is algebraically smaller, differing only in their argument and return types: these functions operate on, respectively, natural size, long, unsigned and unsigned long integers. The imax(), lmax(), max(), and ulmax() functions are identical except that they return the algebraically larger argument between a and b.
SEE ALSO
ilog2(3)
BSD
June 8, 2010 BSD
Related Man Pages
read_random(9) - freebsd
arc4rand(9) - debian
read_random(9) - debian
casueword32(9) - freebsd
math::vecstat(3pm) - debian
Similar Topics in the Unix Linux Community
How to Eliminate first line of multiple files
UrgentPlease: compare 1 value with file values eliminating special characters
count the number of field in a string with deliminter
Date elimination
awk statement to eliminate the duplicates