netbsd man page for hash

Query: hash

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

HASH(9) 						   BSD Kernel Developer's Manual						   HASH(9)

NAME
hash, hash32_buf, hash32_str, hash32_strn -- kernel hash functions
SYNOPSIS
#include <sys/types.h> #include <sys/hash.h> uint32_t hash32_buf(const void *buf, size_t len, uint32_t ihash); uint32_t hash32_str(const void *buf, uint32_t ihash); uint32_t hash32_strn(const void *buf, size_t len, uint32_t ihash);
DESCRIPTION
The hash functions returns a hash of the given buffer. The hash32_buf() function returns a 32 bit hash of buf, which is len bytes long, seeded with an initial hash of ihash (which is usually HASH32_BUF_INIT). This function may use a different algorithm to hash32_str() and hash32_strn(). The hash32_str() function returns a 32 bit hash of buf, which is a NUL terminated ASCII string, seeded with an initial hash of ihash (which is usually HASH32_STR_INIT). This function must use the same algorithm as hash32_strn(), so that the same data returns the same hash. The hash32_strn() function returns a 32 bit hash of buf, which is a NUL terminated ASCII string, up to a maximum of len bytes, seeded with an initial hash of ihash (which is usually HASH32_STR_INIT). This function must use the same algorithm as hash32_str(), so that the same data returns the same hash. The ihash parameter is provided to allow for incremental hashing by allowing successive calls to use a previous hash value.
RETURN VALUES
The hash32_* functions return a 32 bit hash of the provided buffer.
HISTORY
The kernel hashing API first appeared in NetBSD 1.6.
BSD
December 5, 2001 BSD
Related Man Pages
hash32_stre(9) - debian
hash32_buf(9) - debian
hash(9) - netbsd
hash32(9) - freebsd
hash32_buf(9) - freebsd
Similar Topics in the Unix Linux Community
Determining number of overlaps between two files using Hashes?
parse csv file, sha1 hash and output
Algorthm bug of my code
sed hash in multiple lines
Decrypt ssha1 password