netbsd man page for enxio

Query: enxio

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

NULLOP(9)						   BSD Kernel Developer's Manual						 NULLOP(9)

NAME
nullop -- dummy functions
SYNOPSIS
#include <sys/systm.h> int nullop(void *v); void voidop(void); int enodev(void); int enxio(void); int enoioctl(void); int enosys(void); int eopnotsupp(void);
DESCRIPTION
The nullop() function provides a generic ``null operation''. It always returns the value 0. The voidop() function takes no arguments and does nothing. The enodev(), enxio(), enoioctl(), enosys(), and eopnotsupp() functions always fail, returning ENODEV, ENXIO, ENOTTY, ENOSYS, and EOPNOTSUPP, respectively.
EXAMPLES
The following example demonstrates a case where nullop() may be useful: uint64_t xc; ... xc = xc_broadcast(0, (xcfunc_t)nullop, NULL, NULL); xc_wait(xc);
BSD
July 25, 2010 BSD
Related Man Pages
suswintr(9) - debian
suword(9) - debian
suword16(9) - debian
suword64(9) - debian
ucas(9) - netbsd
Similar Topics in the Unix Linux Community
need help about get errno [ENXIO] for mmap