netbsd man page for curcpu

Query: curcpu

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CURPROC(9)						   BSD Kernel Developer's Manual						CURPROC(9)

NAME
curproc, curcpu, curlwp -- current process, processor, and LWP
SYNOPSIS
#include <sys/proc.h> struct cpu_info * curcpu(void); struct proc * curproc(void); struct lwp * curlwp(void);
DESCRIPTION
The following macros can be used to retrieve the current processor, process, and light-weight process (LWP), respectively: 1. The machine-dependent curcpu() macro returns a pointer to a cpu_info structure containing information of the CPU that this thread is running on. 2. The machine-independent curproc() macro refers to a pointer to the process currently running on this CPU. 3. The curlwp() macro expands to a pointer to lwp structure, containing information about the current LWP. This macro is machine- independent, but machine-dependent <machine/cpu.h> may redefine it.
SEE ALSO
cpu_number(9), proc_find(9)
BSD
July 1, 2010 BSD
Related Man Pages
pmc_enabled(9) - netbsd
pmc_enable_counter(9) - netbsd
_lwp_create(2) - netbsd
_lwp_unpark(2) - netbsd
pmc_accumulate(9) - netbsd
Similar Topics in the Unix Linux Community
Memory Leaks
NetBSD 6.1.2: apm and admd not found
Make bold chars in UNIX
BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD
Grep command to show the number of results