Query: ctob
OS: netbsd
Section: 9
Links: netbsd man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
CTOD(9) BSD Kernel Developer's Manual CTOD(9)NAMEctod -- macros related to bytes, pages, and disk blocksSYNOPSIS#include <sys/param.h> size ctod(size x); size dtoc(size x); size ctob(size x); size btoc(size x); size dbtob(size x); size btodb(size x);DESCRIPTIONThe ctod family of macros can be used to convert between bytes, pages (``clicks''), and disk blocks. The following table lists the possible conversions: Macro From To ctod() pages disk blocks dtoc() disk blocks pages ctob() pages bytes btoc() bytes pages dbtob() disk blocks bytes btodb() bytes disk blocks These are typical macros that may appear with different names in other operating systems. Examples include btop() and btopr() in Solaris.SEE ALSOparam(3)HISTORYSome of these macros appeared in Version 7 AT&T UNIX.CAVEATSThe described macros make no assumptions about the type of the input parameter. A caller should ensure that neither integer overflow nor integer underflow are possible.BSDApril 8, 2011 BSD
Related Man Pages |
---|
max(3) - netbsd |
param(3) - netbsd |
roundup(9) - netbsd |
btop(9f) - sunos |
btop(9f) - linux |