netbsd man page for ctassert

Query: ctassert

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CTASSERT(9)						   BSD Kernel Developer's Manual					       CTASSERT(9)

NAME
CTASSERT -- compile time assertion macro
SYNOPSIS
void CTASSERT(expression);
DESCRIPTION
The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it is false. The CTASSERT() macro is useful for asserting the size or alignment of important data structures and variables during compilation, which would otherwise cause the code to fail at run time.
IMPLEMENTATION NOTES
The CTASSERT() macro should not be used in a header file. It is implemented using a dummy typedef, with a name (based on line number) that may conflict with a CTASSERT() in a source file including that header.
EXAMPLES
Assert that the size of the uuid structure is 16 bytes. CTASSERT(sizeof(struct uuid) == 16);
SEE ALSO
KASSERT(9)
AUTHORS
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
BSD
January 24, 2010 BSD
Related Man Pages
assert(3) - redhat
if_my(4) - freebsd
assert(3) - netbsd
kdassertmsg(9) - netbsd
assert.h(3head) - centos
Similar Topics in the Unix Linux Community
Unix File Permissions
How to install PGX32 on Sparc 10 Ultra?
RFC - Korn shell prompt
BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD
Grep command to show the number of results