netbsd man page for cpu_rootconf

Query: cpu_rootconf

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CPU_ROOTCONF(9) 					   BSD Kernel Developer's Manual					   CPU_ROOTCONF(9)

NAME
cpu_rootconf, rootconf, setroot -- root file system setup
SYNOPSIS
#include <sys/types.h> #include <sys/systm.h> void cpu_rootconf(void); void rootconf(void); void setroot(device_t bootdv, int bootpartition);
DESCRIPTION
The cpu_rootconf() is a machine-dependent interface invoked during system bootstrap to determine the root file system device and initialize machine-dependent file system state. cpu_rootconf() provides the global variables booted_device, booted_partition, booted_startblk and booted_nblks and invokes the machine-independent function rootconf which rootconf then calls the function setroot to record the boot/root device and the boot partition information for use in machine-independent code. For disk boot, if booted_nblks is not 0, then booted_startblk and booted_nblks are supposed to specify a disk wedge that is used as the root device. Otherwise the booted_partition is used.
SEE ALSO
boot(8), boothowto(9), dk(4)
BSD
April 13, 2010 BSD
Related Man Pages
installgrub(1m) - sunos
installgrub(1m) - minix
installgrub(1m) - debian
installgrub(1m) - php
installgrub(1m) - posix
Similar Topics in the Unix Linux Community
Memory Leaks
Better to Use Return Code or wc -l Output?
RFC - Korn shell prompt
Make bold chars in UNIX