netbsd man page for cpu_idle

Query: cpu_idle

OS: netbsd

Section: 9

Links: netbsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CPU_IDLE(9)						   BSD Kernel Developer's Manual					       CPU_IDLE(9)

NAME
cpu_idle -- machine-dependent processor idling interface
SYNOPSIS
#include <sys/cpu.h> void cpu_idle(void);
DESCRIPTION
cpu_idle() is called by machine-independent code when the processor has nothing to do. It can be used to conserve the processor power, for example. cpu_idle() returns immediately if cpu_need_resched() has been called for the processor after the last call of cpu_idle() or cpu_did_resched() on the processor. cpu_idle() returns as soon as possible when cpu_need_resched() is called for the processor. Otherwise, it returns when- ever it likes. cpu_idle() is called at IPL_NONE, without any locks held.
EXAMPLES
The simplest (and, in some cases, the best) implementation of cpu_idle() is the following. void cpu_idle(void) { /* nothing */ }
SEE ALSO
cpu_need_resched(9), cpu_switchto(9), intro(9), spl(9)
BSD
April 20, 2007 BSD
Related Man Pages
cpu_family(3alleg4) - debian
pset_ctl(2) - hpux
pset_assign_cpu(1) - osf1
psrset(8) - netbsd
cpu_family(3alleg4) - php
Similar Topics in the Unix Linux Community
CPU idle
vmstat displays cpu idle time at 100%
How to get the information about cpu idle from top command?
top is showing 0% cpu Idle
Why CPU idle 0 process nohub lose