netbsd man page for bpf

Query: bpf

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BPF(9)							   BSD Kernel Developer's Manual						    BPF(9)

NAME
bpf -- Berkeley Packet Filter kernel interface
SYNOPSIS
#include <sys/mbuf.h> #include <net/bpf.h>
DESCRIPTION
bpf is called via an operations vector described by the following struct: struct bpf_ops { void (*bpf_attach)(struct ifnet *, u_int, u_int, struct bpf_if **); void (*bpf_detach)(struct ifnet *); void (*bpf_change_type)(struct ifnet *, u_int, u_int); void (*bpf_tap)(struct bpf_if *, u_char *, u_int); void (*bpf_mtap)(struct bpf_if *, struct mbuf *); void (*bpf_mtap2)(struct bpf_if *, void *, u_int, struct mbuf *); void (*bpf_mtap_af)(struct bpf_if *, uint32_t, struct mbuf *); void (*bpf_mtap_et)(struct bpf_if *, uint16_t, struct mbuf *); void (*bpf_mtap_sl_in)(struct bpf_if *, u_char *, struct mbuf **); void (*bpf_mtap_sl_out)(struct bpf_if *, u_char *, struct mbuf *); }; This vector is found from struct bpf_ops * bpf_ops. It is either a ``stub'' implementation or a real implementation, depending on whether bpf is absent or present in the kernel, respectively.
CODE REFERENCES
The bpf implementation is located in sys/net/bpf.c, the stub implementation is in sys/net/bpf_stub.c, and sys/net/bpf.h describes the inter- face.
BSD
June 8, 2010 BSD
Related Man Pages
bpf_filter(9) - debian
bpf_mtap2(9) - debian
bpf_tap(9) - debian
bpfattach(9) - debian
bpf_mtap(9) - freebsd
Similar Topics in the Unix Linux Community
Shell script for field wise record count for different Files .csv files
awk to update unknown value in file using range of another
Matching column value from 2 different file using awk and append value from different column
Copy of &quot;How to create a long list of directories with mkdir?&quot;
A script need help