netbsd man page for bintime_addx

Query: bintime_addx

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BINTIME_ADD(9)						   BSD Kernel Developer's Manual					    BINTIME_ADD(9)

NAME
bintime_add -- operations on ``bintime''
SYNOPSIS
#include <sys/time.h> vid bintime_add(struct bintime *bt, const struct bintime *bt2); void bintime_addx(struct bintime *bt, uint64_t x); void bintime_sub(struct bintime *bt, const struct bintime *bt2); void bintime2timespec(const struct bintime *bt, struct timespec *ts); void timespec2bintime(const struct timespec *ts, struct bintime *bt); void bintime2timeval(const struct bintime *bt, struct timeval *tv); void timeval2bintime(const struct timeval *tv, struct bintime *bt);
DESCRIPTION
These functions are provided for convenience as part of the machine-independent timecounter(9) framework. All of them operate with the bintime structure. The function bintime_add() adds the time information stored in bt2 to bt. Conversely, bintime_sub() subtracts bt2 from bt. The bintime_addx() function stores the fraction of a second x to bt. Like the function names bespeak, bintime2timespec() converts the bintime structure to struct timespec and timespec2bintime() does the oppo- site. The functions bintime2timeval() and timeval2bintime() operate with struct timeval instead. The result is stored to the right-hand side.
SEE ALSO
timeradd(3), timeval(3), bintime(9), timecounter(9)
BSD
June 8, 2010 BSD
Related Man Pages
getbintime(9) - debian
nanotime(9) - debian
timespec2bintime(9) - netbsd
bintime_add(9) - netbsd
bintime_sub(9) - netbsd
Similar Topics in the Unix Linux Community
How to access a struct within a struct?
Passing pointers to struct
Storing C++-struct in file - problem when adding new item in struct
search file and put into struct
Implementing function outside struct