mojave man page for scsi_destroy_pkt

Query: scsi_destroy_pkt

OS: mojave

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_destroy_pkt(9F)					   Kernel Functions for Drivers 				      scsi_destroy_pkt(9F)

NAME
scsi_destroy_pkt - free an allocated SCSI packet and its DMA resource
SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_destroy_pkt(struct scsi_pkt *pktp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
pktp Pointer to a scsi_pkt(9S) structure.
DESCRIPTION
scsi_destroy_pkt() releases all necessary resources, typically at the end of an I/O transfer. The data is synchronized to memory, then the DMA resources are deallocated and pktp is freed.
CONTEXT
scsi_destroy_pkt() may be called from user or interrupt context.
EXAMPLES
Example 1: Releasing resources. scsi_destroy_pkt(un->un_rqs);
SEE ALSO
tran_destroy_pkt(9E), scsi_init_pkt(9F), scsi_pkt(9S) Writing Device Drivers SunOS 5.10 30 Aug 1995 scsi_destroy_pkt(9F)
Related Man Pages
scsi_sync_pkt(9f) - opensolaris
scsi_dmaget(9f) - suse
scsi_dmaget(9f) - minix
scsi_sync_pkt(9f) - posix
scsi_sync_pkt(9f) - osx
Similar Topics in the Unix Linux Community
12-Core MacPro (2013) kernel_task over 1200%
Shopt -s histappend
UNIX tool on MacOS that can increase resolution of a file
My first PERL incarnation... Audio Oscillograph
How can I direct messages from mac console.app to a log file?