mojave man page for rd

Query: rd

OS: mojave

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

RD(9F)							   Kernel Functions for Drivers 						    RD(9F)

NAME
RD, rd - get pointer to the read queue
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> queue_t *RD(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the write queue whose read queue is to be returned.
DESCRIPTION
The RD() function accepts a write queue pointer as an argument and returns a pointer to the read queue of the same module. CAUTION: Make sure the argument to this function is a pointer to a write queue. RD() will not check for queue type, and a system panic could result if it is not the right type.
RETURN VALUES
The pointer to the read queue.
CONTEXT
RD() can be called from user or interrupt context.
EXAMPLES
Example 1: Function page reference See the qreply(9F) function page for an example of RD().
SEE ALSO
qreply(9F), WR(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 15 Nov 1991 RD(9F)
Related Man Pages
wr(9f) - sunos
wr(9f) - osx
wr(9f) - debian
wr(9f) - php
rd(9f) - freebsd
Similar Topics in the Unix Linux Community
Who is Perderabo?
Count the number of occurence of perticular word from file
Infraction system (formerly: Please Moderate Words Like &quot;Hell&quot;)
Copy file to SD card from internal flash.
How to find the number of occurence of particular word from a text file?