Query: magic
OS: mojave
Section: 5
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
MAGIC(5) BSD File Formats Manual MAGIC(5)NAMEmagic -- file command's magic pattern fileDESCRIPTIONThis manual page documents the format of magic files as used by the file(1) command, version 5.04. The file(1) command identifies the type of a file using, among other tests, a test for whether the file contains certain ``magic patterns''. The database of these ``magic patterns'' is usually located in a binary file in /usr/share/file/magic.mgc or a directory of source text magic pattern fragment files in /usr/share/file/magic. The database specifies what patterns are to be tested for, what message or MIME type to print if a particular pattern is found, and additional information to extract from the file. The format of the source fragment files that are used to build this database is as follows: Each line of a fragment file specifies a test to be performed. A test compares the data starting at a particular offset in the file with a byte value, a string or a numeric value. If the test succeeds, a message is printed. The line consists of the following fields: offset A number specifying the offset (in bytes) into the file of the data which is to be tested. This offset can be a negative number if it is: o The first direct offset of the magic entry (at continuation level 0), in which case it is interpreted an offset from end end of the file going backwards. This works only when a file descriptor to the file is a available and it is a regular file. o A continuation offset relative to the end of the last up-level field (&). type The type of the data to be tested. The possible values are: byte A one-byte value. short A two-byte value in this machine's native byte order. long A four-byte value in this machine's native byte order. quad An eight-byte value in this machine's native byte order. float A 32-bit single precision IEEE floating point number in this machine's native byte order. double A 64-bit double precision IEEE floating point number in this machine's native byte order. string A string of bytes. The string type specification can be optionally followed by /[WwcCtbT]*. The ``W'' flag compacts whitespace in the target, which must contain at least one whitespace character. If the magic has n consecutive blanks, the target needs at least n consecutive blanks to match. The ``w'' flag treats every blank in the magic as an optional blank. The ``c'' flag specifies case insensitive matching: lower case characters in the magic match both lower and upper case characters in the target, whereas upper case characters in the magic only match upper case characters in the target. The ``C'' flag specifies case insensitive matching: upper case characters in the magic match both lower and upper case characters in the target, whereas lower case characters in the magic only match upper case characters in the target. To do a complete case insensitive match, specify both ``c'' and ``C''. The ``t'' flag forces the test to be done for text files, while the ``b'' flag forces the test to be done for binary files. The ``T'' flag causes the string to be trimmed, i.e. leading and trailing whitespace is deleted before the string is printed. pstring A Pascal-style string where the first byte/short/int is interpreted as the unsigned length. The length defaults to byte and can be specified as a modifier. The following modifiers are supported: B A byte length (default). H A 4 byte big endian length. h A 2 byte big endian length. L A 4 byte little endian length. l A 2 byte little endian length. J The length includes itself in its count. The string is not NUL terminated. ``J'' is used rather than the more valuable ``I'' because this type of length is a feature of the JPEG format. date A four-byte value interpreted as a UNIX date. qdate A eight-byte value interpreted as a UNIX date. ldate A four-byte value interpreted as a UNIX-style date, but interpreted as local time rather than UTC. qldate An eight-byte value interpreted as a UNIX-style date, but interpreted as local time rather than UTC. qwdate An eight-byte value interpreted as a Windows-style date. beid3 A 32-bit ID3 length in big-endian byte order. beshort A two-byte value in big-endian byte order. belong A four-byte value in big-endian byte order. bequad An eight-byte value in big-endian byte order. befloat A 32-bit single precision IEEE floating point number in big-endian byte order. bedouble A 64-bit double precision IEEE floating point number in big-endian byte order. bedate A four-byte value in big-endian byte order, interpreted as a Unix date. beqdate An eight-byte value in big-endian byte order, interpreted as a Unix date. beldate A four-byte value in big-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC. beqldate An eight-byte value in big-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC. beqwdate An eight-byte value in big-endian byte order, interpreted as a Windows-style date. bestring16 A two-byte unicode (UCS16) string in big-endian byte order. leid3 A 32-bit ID3 length in little-endian byte order. leshort A two-byte value in little-endian byte order. lelong A four-byte value in little-endian byte order. lequad An eight-byte value in little-endian byte order. lefloat A 32-bit single precision IEEE floating point number in little-endian byte order. ledouble A 64-bit double precision IEEE floating point number in little-endian byte order. ledate A four-byte value in little-endian byte order, interpreted as a UNIX date. leqdate An eight-byte value in little-endian byte order, interpreted as a UNIX date. leldate A four-byte value in little-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC. leqldate An eight-byte value in little-endian byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC. leqwdate An eight-byte value in little-endian byte order, interpreted as a Windows-style date. lestring16 A two-byte unicode (UCS16) string in little-endian byte order. melong A four-byte value in middle-endian (PDP-11) byte order. medate A four-byte value in middle-endian (PDP-11) byte order, interpreted as a UNIX date. meldate A four-byte value in middle-endian (PDP-11) byte order, interpreted as a UNIX-style date, but interpreted as local time rather than UTC. indirect Starting at the given offset, consult the magic database again. The offset of the indirect magic is by default absolute in the file, but one can specify /r to indicate that the offset is relative from the beginning of the entry. name Define a ``named'' magic instance that can be called from another use magic entry, like a subroutine call. Named instance direct magic offsets are relative to the offset of the previous matched entry, but indirect offsets are rela- tive to the beginning of the file as usual. Named magic entries always match. use Recursively call the named magic starting from the current offset. If the name of the referenced begins with a ^ then the endianness of the magic is switched; if the magic mentioned leshort for example, it is treated as beshort and vice versa. This is useful to avoid duplicating the rules for different endianness. regex A regular expression match in extended POSIX regular expression syntax (like egrep). Regular expressions can take expo- nential time to process, and their performance is hard to predict, so their use is discouraged. When used in production environments, their performance should be carefully checked. The size of the string to search should also be limited by specifying /<length>, to avoid performance issues scanning long files. The type specification can also be optionally followed by /[c][s][l]. The ``c'' flag makes the match case insensitive, while the ``s'' flag update the offset to the start offset of the match, rather than the end. The ``l'' modifier, changes the limit of length to mean number of lines instead of a byte count. Lines are delimited by the platforms native line delimiter. When a line count is specified, an implicit byte count also computed assuming each line is 80 characters long. If neither a byte or line count is spec- ified, the search is limited automatically to 8KiB. ^ and $ match the beginning and end of individual lines, respec- tively, not beginning and end of file. search A literal string search starting at the given offset. The same modifier flags can be used as for string patterns. The search expression must contain the range in the form /number, that is the number of positions at which the match will be attempted, starting from the start offset. This is suitable for searching larger binary expressions with variable off- sets, using escapes for special characters. The order of modifier and number is not relevant. default This is intended to be used with the test x (which is always true) and it has no type. It matches when no other test at that continuation level has matched before. Clearing that matched tests for a continuation level, can be done using the clear test. clear This test is always true and clears the match flag for that continuation level. It is intended to be used with the default test. For compatibility with the Single UNIX Standard, the type specifiers dC and d1 are equivalent to byte, the type specifiers uC and u1 are equivalent to ubyte, the type specifiers dS and d2 are equivalent to short, the type specifiers uS and u2 are equivalent to ushort, the type specifiers dI, dL, and d4 are equivalent to long, the type specifiers uI, uL, and u4 are equivalent to ulong, the type specifier d8 is equivalent to quad, the type specifier u8 is equivalent to uquad, and the type specifier s is equivalent to string. In addition, the type specifier dQ is equivalent to quad and the type specifier uQ is equivalent to uquad. Each top-level magic pattern (see below for an explanation of levels) is classified as text or binary according to the types used. Types ``regex'' and ``search'' are classified as text tests, unless non-printable characters are used in the pattern. All other tests are classified as binary. A top-level pattern is considered to be a test text when all its patterns are text patterns; other- wise, it is considered to be a binary pattern. When matching a file, binary patterns are tried first; if no match is found, and the file looks like text, then its encoding is determined and the text patterns are tried. The numeric types may optionally be followed by & and a numeric value, to specify that the value is to be AND'ed with the numeric value before any comparisons are done. Prepending a u to the type indicates that ordered comparisons should be unsigned. test The value to be compared with the value from the file. If the type is numeric, this value is specified in C form; if it is a string, it is specified as a C string with the usual escapes permitted (e.g. for new-line). Numeric values may be preceded by a character indicating the operation to be performed. It may be =, to specify that the value from the file must equal the specified value, <, to specify that the value from the file must be less than the specified value, >, to specify that the value from the file must be greater than the specified value, &, to specify that the value from the file must have set all of the bits that are set in the specified value, ^, to specify that the value from the file must have clear any of the bits that are set in the specified value, or ~, the value specified after is negated before tested. x, to specify that any value will match. If the character is omitted, it is assumed to be =. Operators &, ^, and ~ don't work with floats and doubles. The operator ! specifies that the line matches if the test does not succeed. Numeric values are specified in C form; e.g. 13 is decimal, 013 is octal, and 0x13 is hexadecimal. Numeric operations are not performed on date types, instead the numeric value is interpreted as an offset. For string values, the string from the file must match the specified string. The operators =, < and > (but not &) can be applied to strings. The length used for matching is that of the string argument in the magic file. This means that a line can match any non- empty string (usually used to then print the string), with >