Query: makedevice
OS: minix
Section: 9f
Links: minix man pages all man pages forum categories
Format:Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
makedevice(9F) Kernel Functions for Drivers makedevice(9F)NAMEmakedevice - make device number from major and minor numbersSYNOPSIS#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> dev_t makedevice(major_t majnum, minor_t minnum);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSmajnum Major device number. minnum Minor device number.DESCRIPTIONmakedevice() creates a device number from a major and minor device number. makedevice() should be used to create device numbers so the driver will port easily to releases that treat device numbers differently.RETURN VALUESThe device number, containing both the major number and the minor number, is returned. No validation of the major or minor numbers is per- formed.CONTEXTmakedevice() can be called from user or interrupt context.SEE ALSOgetmajor(9F), getminor(9F) SunOS 5.10 11 Apr 1991 makedevice(9F)