Query: zpfind
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PFIND(9) BSD Kernel Developer's Manual PFIND(9)NAMEpfind, zpfind -- locate a process by numberSYNOPSIS#include <sys/param.h> #include <sys/proc.h> struct proc * pfind(pid_t pid); struct proc * zpfind(pid_t pid);DESCRIPTIONpfind() takes a pid as its argument and returns a pointer to the proc structure whose PID is specified in the argument only if the pid is on the allproc list. zpfind() takes a pid as its argument. If zpfind() finds a process whose PID is equal to that of argument and is a zombie process, meaning that it must reside on the zombproc list, zpfind() returns a pointer to that proc structure. Both pfind() and zpfind() lock the proc structure that is returned using PROC_LOCK(p).RETURN VALUESpfind() and zpfind() return a pointer to a proc structure on success and a NULL on failure.SEE ALSOpgfind(9)AUTHORSThis manual page was written by Evan Sarmiento <kaworu@sektor7.ath.cx>.BSDJuly 11, 2001 BSD
Related Man Pages |
---|
kvm_nextproc(3kvm) - opensolaris |
nsenter(1) - centos |
setpgrp(2) - netbsd |
kvm_setproc(3kvm) - opensolaris |
kvm_nextproc(3kvm) - opendarwin |
Similar Topics in the Unix Linux Community |
---|
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick |
Memory Leaks |
UNIX Environment Setup - (Just starting!) |