freebsd man page for vslock

Query: vslock

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VSLOCK(9)						   BSD Kernel Developer's Manual						 VSLOCK(9)

NAME
vslock, vsunlock -- lock/unlock user space addresses in memory
SYNOPSIS
#include <sys/param.h> #include <sys/proc.h> #include <vm/vm.h> #include <vm/vm_extern.h> int vslock(void *addr, size_t len); void vsunlock(void *addr, size_t len);
DESCRIPTION
The vslock() and vsunlock() functions respectively lock and unlock a range of addresses belonging to the currently running process into mem- ory. The actual amount of memory locked is a multiple of the machine's page size. The starting page number is computed by truncating addr to the nearest preceding page boundary, and by rounding up addr + len to the next page boundary. The process context to use for this opera- tion is taken from the global variable curproc.
RETURN VALUES
The vslock() function will return 0 on success, otherwise it will return one of the errors listed below.
ERRORS
The vslock() function will fail if: [EINVAL] The addr and len parameters specify a memory range that wraps around the end of the machine address space. [ENOMEM] The size of the specified address range exceeds the system limit on locked memory. [EFAULT] Some portion of the indicated address range is not allocated. There was an error faulting/mapping a page.
BSD
August 29, 2012 BSD
Related Man Pages
vsunlock(9) - debian
mlock(2) - netbsd
munlock(2) - netbsd
munlock(3) - osf1
munlock(2) - osx
Similar Topics in the Unix Linux Community
Memory Leaks
Is UNIX an open source OS ?
A simple UNIXtime component in Vue.js
Reason for no directory creation date
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?