freebsd man page for vop_strategy

Query: vop_strategy

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_STRATEGY(9) 					   BSD Kernel Developer's Manual					   VOP_STRATEGY(9)

NAME
VOP_STRATEGY -- read or write a file system buffer
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_STRATEGY(struct vnode *vp, struct buf *bp);
DESCRIPTION
The arguments are: vp The vnode that the buffer is for. bp The buffer to be read or written. This call either reads or writes data from a file, depending on the value of bp->b_io.bio_cmd. The call may block.
RETURN VALUES
Always zero. Errors should be signalled by setting BIO_ERROR on b_ioflags field in struct buf, and setting b_error to the appropriate errno value.
SEE ALSO
buf(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
February 2, 2014 BSD
Related Man Pages
vput(9) - freebsd
vop_vptocnp(9) - centos
vop_vptocnp(9) - php
vop_vptocnp(9) - minix
vop_vptocnp(9) - redhat
Similar Topics in the Unix Linux Community
Unix File Permissions
Memory Leaks
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)