freebsd man page for vm_page_lookup

Query: vm_page_lookup

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_PAGE_LOOKUP(9)					   BSD Kernel Developer's Manual					 VM_PAGE_LOOKUP(9)

NAME
vm_page_lookup -- lookup a vm page
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> vm_page_t vm_page_lookup(vm_object_t object, vm_pindex_t pindex);
DESCRIPTION
The vm_page_lookup() function searches for a VM page given its VM object and index. If the page is not found, NULL is returned. Its argu- ments are: object The VM object to search on. pindex The page index to search on.
RETURN VALUES
A vm_page_t is returned if successful; otherwise, NULL is returned.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 13, 2001 BSD
Related Man Pages
vm_page_free(9) - freebsd
vm_page_grab(9) - freebsd
vm_page_free_zero(9) - freebsd
vm_page_insert(9) - freebsd
vm_page_remove(9) - freebsd
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Memory Leaks
UNIX Environment Setup - (Just starting!)