freebsd man page for vm_page_cache

Query: vm_page_cache

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_PAGE_CACHE(9)					   BSD Kernel Developer's Manual					  VM_PAGE_CACHE(9)

NAME
vm_page_cache -- move a page onto the cache queue
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> void vm_page_cache(vm_page_t m);
DESCRIPTION
The vm_page_cache() function moves a page onto the cache queue, and removes any protection that may be set on the page. If the page is busy, wired or unmanaged then the move to the cache queue will fail. If the page is dirty the system will panic.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 24, 2001 BSD
Related Man Pages
vm_page_free(9) - freebsd
vm_page_unhold(9) - freebsd
vm_page_free(9) - opensolaris
vm_page_free(9) - hpux
vm_page_free(9) - minix
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang
Is UNIX an open source OS ?
Controlling user input