freebsd man page for vm_map_init

Query: vm_map_init

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_MAP_INIT(9)						   BSD Kernel Developer's Manual					    VM_MAP_INIT(9)

NAME
vm_map_init -- initialize a vm_map structure for process zero
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> void vm_map_init(vm_map_t map, vm_offset_t min, vm_offset_t max);
DESCRIPTION
The vm_map_init() function initializes the system map map by setting its upper and lower address bounds to max and min respectively. It also initializes the system map mutex.
IMPLEMENTATION NOTES
This routine is for internal use only. It is called during early system initialization.
SEE ALSO
vm_map(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 19, 2003 BSD
Related Man Pages
vm_map_protect(9) - debian
vm_map_protect(9) - freebsd
vm_map_insert(9) - freebsd
vm_map_insert(9) - linux
vm_map_findspace(9) - linux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang