Query: vm_map_inherit
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VM_MAP_INHERIT(9) BSD Kernel Developer's Manual VM_MAP_INHERIT(9)NAMEvm_map_inherit -- set fork inheritance flags for a range within a mapSYNOPSIS#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_map.h> int vm_map_inherit(vm_map_t map, vm_offset_t start, vm_offset_t end, vm_inherit_t new_inheritance);DESCRIPTIONThe vm_map_inherit() function sets the inheritance flags for the range start to end within the target map to the value new_inheritance. The new_inheritance flag must have one of the values VM_INHERIT_NONE, VM_INHERIT_COPY, or VM_INHERIT_SHARE. This affects how the map will be shared with child maps when the associated process forks.IMPLEMENTATION NOTESThe vm_map_inherit() function obtains a lock on the map using vm_map_lock(9) for the duration of the function.RETURN VALUESThe vm_map_inherit() function returns KERN_SUCCESS if the inheritance flags could be set. Otherwise, if the provided flags were invalid, KERN_INVALID_ARGUMENT will be returned.SEE ALSOfork(2)AUTHORSThis manual page was written by Bruce M Simpson <bms@spc.org>.BSDJuly 19, 2003 BSD
Related Man Pages |
---|
vm_map_clean(9) - debian |
vm_map_unwire(9) - debian |
vm_map_protect(9) - freebsd |
vm_map_unwire(9) - freebsd |
vm_map_submap(9) - linux |
Similar Topics in the Unix Linux Community |
---|
Mac OS X: Based on UNIX - Solid As a Rock |
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick |
Memory Leaks |
Is UNIX an open source OS ? |
A simple UNIXtime component in Vue.js |