freebsd man page for vgone

Query: vgone

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VGONE(9)						   BSD Kernel Developer's Manual						  VGONE(9)

NAME
vgone -- prepare a vnode for reuse
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vgone(struct vnode *vp);
DESCRIPTION
The vgone() function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list. If the vnode has a v_usecount of zero, and its VI_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode is about to be reused, or its file system is being unmounted. The vgone() function takes an exclusively locked vnode, and returns with the vnode exclusively locked.
SEE ALSO
vnode(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
November 12, 2010 BSD
Related Man Pages
insmntque(9) - debian
vput(9) - debian
vunref(9) - debian
vput(9) - opensolaris
vrele(9) - centos
Similar Topics in the Unix Linux Community
Scripts without shebang
Is UNIX an open source OS ?
Reason for no directory creation date
Valid separator in time and date format