freebsd man page for vfs_unmount

Query: vfs_unmount

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_UNMOUNT(9)						   BSD Kernel Developer's Manual					    VFS_UNMOUNT(9)

NAME
VFS_UNMOUNT -- unmount a file system
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_UNMOUNT(struct mount *mp, int mntflags);
DESCRIPTION
The VFS_UNMOUNT() macro unmounts a file system. The arguments it expects are: mp The file system. mntflags Bit-mask of flags for the unmount operation. The flags currently supported by VFS_UNMOUNT() are: MNT_FORCE Open files are forcibly closed before the file system is unmounted.
SEE ALSO
vflush(9), VFS(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 23, 2009 BSD
Related Man Pages
vfs_vget(9) - debian
vfs_fhtovp(9) - netbsd
vfs_start(9) - netbsd
vfs_statvfs(9) - netbsd
vfs_suspendctl(9) - netbsd
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
Memory Leaks
Controlling user input