freebsd man page for vfs_timestamp

Query: vfs_timestamp

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_TIMESTAMP(9)					   BSD Kernel Developer's Manual					  VFS_TIMESTAMP(9)

NAME
vfs_timestamp -- generate current timestamp
SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vfs_timestamp(struct timespec *tsp);
DESCRIPTION
The vfs_timestamp() function fills in tsp with the current time. The precision is based on the value of the vfs.timestamp_precision sysctl variable: 0 seconds only; nanoseconds are zeroed. 1 seconds and nanoseconds, accurate within 1/HZ. 2 seconds and nanoseconds, truncated to microseconds. >=3 seconds and nanoseconds, maximum precision.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
November 21, 2001 BSD
Related Man Pages
timespec_to_timeval(3) - netbsd
timespec(3) - netbsd
pthread_get_expiration_np(3) - osf1
insmntque(9) - freebsd
insmntque1(9) - freebsd
Similar Topics in the Unix Linux Community
Memory Leaks
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?