freebsd man page for vfs_root

Query: vfs_root

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_ROOT(9)						   BSD Kernel Developer's Manual					       VFS_ROOT(9)

NAME
VFS_ROOT -- return the root vnode of a file system
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_ROOT(struct mount *mp, int flags, struct vnode **vpp);
DESCRIPTION
Return a locked vnode for the root directory of the file system. Its arguments are: mp The file system. flags The lock type. Could be LK_EXCLUSIVE or LK_SHARED. File system is free to ignore the flags argument and instead acquire an exclusive lock. vpp Return parameter for the root vnode.
SEE ALSO
VFS(9), vnode(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
May 23, 2009 BSD
Related Man Pages
vfs_fhtovp(9) - debian
vfs_vget(9) - debian
vop_lock(9) - debian
vfs_fhtovp(9) - linux
vfs_fhtovp(9) - hpux
Similar Topics in the Unix Linux Community
Error while installing zoning
How to make smtp:sendmail online from maintenance mode?