freebsd man page for securelevel_gt

Query: securelevel_gt

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SECURELEVEL_GT(9)					   BSD Kernel Developer's Manual					 SECURELEVEL_GT(9)

NAME
securelevel_gt, securelevel_ge -- test active securelevel
SYNOPSIS
#include <sys/types.h> #include <sys/proc.h> int securelevel_gt(struct ucred *cr, int level); int securelevel_ge(struct ucred *cr, int level);
DESCRIPTION
These functions test the active security level against the given level. If the calling credential cr was imprisoned by the jail(2) system call, and has a different security level set than the host environment, the security level with the highest value is used. The securelevel_gt() function will evaluate whether or not the active security level is greater than the supplied level. The securelevel_ge() function will evaluate whether or not the active security level is greater than or equal to the supplied level.
RETURN VALUES
These functions return EPERM if condition evaluated to true, and 0 otherwise.
SEE ALSO
securelevel(7)
BSD
June 2, 2007 BSD
Related Man Pages
cr_seeothergids(9) - debian
p_candebug(9) - debian
splraiseipl(9) - netbsd
p_candebug(9) - freebsd
p_candebug(9) - linux
Similar Topics in the Unix Linux Community
Unix File Permissions
The Whole Story on #! /usr/bin/ksh
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?