freebsd man page for prison_check

Query: prison_check

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PRISON_CHECK(9) 					   BSD Kernel Developer's Manual					   PRISON_CHECK(9)

NAME
prison_check -- determine if two credentials belong to the same jail
SYNOPSIS
#include <sys/jail.h> int prison_check(struct ucred *cred1, struct ucred *cred2);
DESCRIPTION
This function can be used to determine if the two credentials cred1 and cred2 belong to the same jail.
RETURN VALUES
The prison_check() function returns ESRCH if cred1 has been jailed, and cred1 and cred2 do not belong to the same jail. In all other cases, prison_check() returns zero.
SEE ALSO
jail(2)
BSD
December 11, 2003 BSD
Related Man Pages
cr_seeothergids(9) - debian
p_cansee(9) - freebsd
p_candebug(9) - freebsd
p_candebug(9) - linux
p_cansee(9) - linux
Similar Topics in the Unix Linux Community
Unix File Permissions
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Memory Leaks
Valid separator in time and date format