freebsd man page for pmap_zero_page

Query: pmap_zero_page

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_ZERO(9)						   BSD Kernel Developer's Manual					      PMAP_ZERO(9)

NAME
pmap_zero_page, pmap_zero_area, pmap_zero_idle -- zero-fill a page using machine-dependent optimizations
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_zero_page(vm_page_t m); void pmap_zero_page_area(vm_page_t m, int off, int size); void pmap_zero_page_idle(vm_page_t m);
DESCRIPTION
The pmap_zero_page() function zero-fills an entire page using machine-dependent optimizations. The pmap_zero_page_area() function is used to zero-fill an area of a page. The range specified must not cross a page boundary; it must be contained entirely within a single page. The pmap_zero_page_idle() interface is used by the vm_pagezero process. The system-wide Giant lock should not be required to be held in order to call this interface.
IMPLEMENTATION NOTES
This function is required to be implemented for each architecture supported by FreeBSD.
SEE ALSO
bzero(3), pmap(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
vm_page_free(9) - freebsd
pmap_extract_and_hold(9) - debian
vm_page_free_zero(9) - debian
vm_page_insert(9) - debian
pmap_object_init_pt(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Memory Leaks
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?