freebsd man page for pmap_ts_modified

Query: pmap_ts_modified

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_IS_MODIFIED(9)					   BSD Kernel Developer's Manual				       PMAP_IS_MODIFIED(9)

NAME
pmap_is_modified, pmap_ts_modified -- return information about physical pages
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> boolean_t pmap_is_modified(vm_page_t m); int pmap_ts_referenced(vm_page_t m);
DESCRIPTION
The pmap_is_modified() and pmap_ts_referenced() functions return information about physical pages.
RETURN VALUES
The pmap_is_modified() function returns the status of the ``page modified'' bit for the physical page m. The pmap_ts_referenced() function returns a count of reference bits for a page m, clearing those bits. It is not necessary for every refer- ence bit to be cleared, but it is necessary that 0 only be returned when there are no remaining reference bits set on the page.
SEE ALSO
pmap(9), pmap_clear_modify(9), pmap_clear_reference(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
vm_fault_prefault(9) - debian
vm_page_bits(9) - debian
pmap_object_init_pt(9) - freebsd
vm_page_aflag_set(9) - freebsd
vm_page_aflag_clear(9) - freebsd
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Is UNIX an open source OS ?
A simple UNIXtime component in Vue.js
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)