freebsd man page for pmap_qremove

Query: pmap_qremove

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_QENTER(9)						   BSD Kernel Developer's Manual					    PMAP_QENTER(9)

NAME
pmap_qenter, pmap_qremove -- manage temporary kernel space mappings
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_qenter(vm_offset_t sva, vm_page_t *m, int count); void pmap_qremove(vm_offset_t sva, int count);
DESCRIPTION
The pmap_qenter() function accepts a linear array of count pointers to wired pages *m, and enters each of these pages into the kernel virtual address (KVA) space, beginning at the address sva. The pmap_qremove() function tears out a mapping from the kernel virtual address space, beginning at sva and for count pages.
IMPLEMENTATION NOTES
The pmap_qenter() function is intended for temporary mappings that do not require page modification or reference counting. Old mappings are simply overwritten. The pages must be wired into physical memory. The corresponding pmap_qremove() function is intended to remove such temporary mappings.
SEE ALSO
pmap(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
sf_buf_free(9) - freebsd
vm_fault_prefault(9) - freebsd
sf_buf(9) - debian
sf_buf_free(9) - debian
sf_buf_kva(9) - debian
Similar Topics in the Unix Linux Community
Scripts without shebang
Is UNIX an open source OS ?
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)
Controlling user input