freebsd man page for pmap_pinit

Query: pmap_pinit

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_PINIT(9)						   BSD Kernel Developer's Manual					     PMAP_PINIT(9)

NAME
pmap_pinit, pmap_pinit0 -- initialize pmap structures
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_pinit(pmap_t pmap); void pmap_pinit0(pmap_t pm);
DESCRIPTION
The pmap_pinit() function initializes the preallocated and zeroed structure pmap, such as one in a vmspace structure. The pmap_pinit0() function initializes the physical map pm, associated with process 0, the first process created in the system.
IMPLEMENTATION NOTES
The pmap_pinit2() function has been deprecated, and should be implemented as a stub until further notice.
SEE ALSO
pmap(9), pmap_growkernel(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
pmap(9) - debian
vm_page_remove(9) - debian
pmap_enter(9) - freebsd
pmap_extract_and_hold(9) - freebsd
vm_map_findspace(9) - linux
Similar Topics in the Unix Linux Community
Unix File Permissions
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
UNIX Environment Setup - (Just starting!)
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?