freebsd man page for pmap_page_protect

Query: pmap_page_protect

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_PROTECT(9) 					   BSD Kernel Developer's Manual					   PMAP_PROTECT(9)

NAME
pmap_page_protect, pmap_protect -- set physical page protection
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_page_protect(vm_page_t m, vm_prot_t prot); void pmap_protect(pmap_t pmap, vm_offset_t sva, vm_offset_t eva, vm_prot_t pr);
DESCRIPTION
The pmap_page_protect() function lowers the physical page permissions to prot for all mappings of a given page m. The pmap_protect() function sets the physical page permissions to prot for all physical pages in the physical map pmap in the virtual address range between sva and eva.
SEE ALSO
pmap(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
pmap_extract(9) - freebsd
pmap_extract(9) - debian
vm_map_insert(9) - debian
vm_map_protect(9) - debian
vm_map_protect(9) - freebsd
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Scripts without shebang
Memory Leaks
Reason for no directory creation date
Controlling user input