freebsd man page for pmap_mincore

Query: pmap_mincore

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_MINCORE(9) 					   BSD Kernel Developer's Manual					   PMAP_MINCORE(9)

NAME
pmap_mincore -- determine if a virtual address is resident in physical memory
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> int pmap_mincore(pmap_t pmap, vm_offset_t addr);
DESCRIPTION
The pmap_mincore() function determines if the page at the virtual address addr in the physical map pmap is resident in physical memory. It is the machine-dependent interface used by the mincore(2) system call.
RETURN VALUES
If the page is resident in physical memory, a mask of flags is returned, whose meaning is documented in mincore(2); otherwise, 0 is returned. The pmap must exist and addr must be mapped into the pmap. If any error occurs, the machine-dependent implementation should return 0.
SEE ALSO
mincore(2), pmap(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
mincore(2) - opensolaris
pmap_extract(9) - debian
pmap_extract_and_hold(9) - debian
mincore(2) - sunos
pmap_extract_and_hold(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
A simple UNIXtime component in Vue.js
Reason for no directory creation date