freebsd man page for pmap_is_prefaultable

Query: pmap_is_prefaultable

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMAP_IS_PREFAULTABLE(9) 				   BSD Kernel Developer's Manual				   PMAP_IS_PREFAULTABLE(9)

NAME
pmap_is_prefaultable -- determine if a page may be prefaulted
SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> boolean_t pmap_is_prefaultable(pmap_t pmap, vm_offset_t va);
DESCRIPTION
The pmap_is_prefaultable() function provides a means of determining if the page residing at virtual address va in the physical map pmap may be pre-faulted into main memory. This is a helper function which is called by vm_fault_prefault(9).
SEE ALSO
pmap(9), vm_fault_prefault(9)
AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>.
BSD
July 21, 2003 BSD
Related Man Pages
vm_map_check_protection(9) - debian
vm_map_protect(9) - debian
vm_map_check_protection(9) - freebsd
pmap(9) - freebsd
pmap_extract_and_hold(9) - freebsd
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Reason for no directory creation date
UNIX Environment Setup - (Just starting!)
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?