freebsd man page for pgfind

Query: pgfind

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PGFIND(9)						   BSD Kernel Developer's Manual						 PGFIND(9)

NAME
pgfind -- locate a process group by number
SYNOPSIS
#include <sys/param.h> #include <sys/proc.h> struct pgrp * pgfind(pid_t pgid);
DESCRIPTION
The pgfind() function takes a pgid as its argument and returns a pointer to the pgrp structure whose pg_id is specified in the argument. pgfind() locks the pgrp structure that is returned.
RETURN VALUES
The pgfind() function returns NULL on failure or a pointer to a pgrp structure on successful completion.
SEE ALSO
pfind(9)
AUTHORS
This manual page was written by Evan Sarmiento <kaworu@sektor7.ath.cx>.
BSD
August 8, 2001 BSD
Related Man Pages
killpg(2) - mojave
gsignal(9) - freebsd
gsignal(9) - debian
pgsignal(9) - freebsd
pgsignal(9) - suse
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
The Whole Story on #! /usr/bin/ksh
Scripts without shebang
UNIX Environment Setup - (Just starting!)