freebsd man page for pfind

Query: pfind

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PFIND(9)						   BSD Kernel Developer's Manual						  PFIND(9)

NAME
pfind, zpfind -- locate a process by number
SYNOPSIS
#include <sys/param.h> #include <sys/proc.h> struct proc * pfind(pid_t pid); struct proc * zpfind(pid_t pid);
DESCRIPTION
pfind() takes a pid as its argument and returns a pointer to the proc structure whose PID is specified in the argument only if the pid is on the allproc list. zpfind() takes a pid as its argument. If zpfind() finds a process whose PID is equal to that of argument and is a zombie process, meaning that it must reside on the zombproc list, zpfind() returns a pointer to that proc structure. Both pfind() and zpfind() lock the proc structure that is returned using PROC_LOCK(p).
RETURN VALUES
pfind() and zpfind() return a pointer to a proc structure on success and a NULL on failure.
SEE ALSO
pgfind(9)
AUTHORS
This manual page was written by Evan Sarmiento <kaworu@sektor7.ath.cx>.
BSD
July 11, 2001 BSD
Related Man Pages
kvm_nextproc(3kvm) - opensolaris
setpgid(2) - netbsd
setpgrp(2) - netbsd
kvm_setproc(3kvm) - sunos
kvm_getproc(3kvm) - opensolaris
Similar Topics in the Unix Linux Community
DupFinder gui 0.12 / console 0.92 (Default branch)
DupFinder gui 0.20 / console 0.92 (Default branch)
depfinder 0.3 (Default branch)
depfinder 0.4 (Default branch)
depfinder 0.5 (Default branch)