freebsd man page for groupmember

Query: groupmember

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

GROUPMEMBER(9)						   BSD Kernel Developer's Manual					    GROUPMEMBER(9)

NAME
groupmember -- checks group set for a group ID
SYNOPSIS
#include <sys/param.h> #include <sys/ucred.h> int groupmember(gid_t gid, struct ucred *cred);
DESCRIPTION
The groupmember() function checks to see if the given gid is in the group set of the credentials. Its arguments are: gid The group ID to check for. cred The credentials to search for the group in.
RETURN VALUES
If the gid is found, 1 is returned; otherwise, 0 is returned.
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 9, 2001 BSD
Related Man Pages
vop_access(9) - freebsd
vop_access(9) - php
vop_access(9) - linux
vop_access(9) - osx
vop_access(9) - suse
Similar Topics in the Unix Linux Community
Warning for sophos: Inappropriate Subject Text (Non Descriptive)
Help with a shell script ?
If first pattern is found, look for second pattern. If second pattern not found, delete line
Cron Job failure - No such file or directory