freebsd man page for getnanouptime

Query: getnanouptime

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

MICROUPTIME(9)						   BSD Kernel Developer's Manual					    MICROUPTIME(9)

NAME
binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime, getnanouptime, sbinuptime, getsbinuptime -- get the time elapsed since boot
SYNOPSIS
#include <sys/time.h> void binuptime(struct bintime *bt); void getbinuptime(struct bintime *bt); void microuptime(struct timeval *tv); void getmicrouptime(struct timeval *tv); void nanouptime(struct timespec *ts); void getnanouptime(struct timespec *tsp); sbintime_t sbinuptime(void); sbintime_t getsbinuptime(void);
DESCRIPTION
The binuptime() and getbinuptime() functions store the time elapsed since boot as a struct bintime at the address specified by bt. The microuptime() and getmicrouptime() functions perform the same utility, but record the elapsed time as a struct timeval instead. Similarly the nanouptime() and getnanouptime() functions store the elapsed time as a struct timespec. The sbinuptime() and getsbinuptime() functions return the time elapsed since boot as a sbintime_t. The binuptime(), microuptime(), nanouptime(), and sbinuptime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbinuptime(), getmicrouptime(), getnanouptime(), and getsbinuptime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbinuptime(), getmicrouptime(), getnanouptime(), and getsbinuptime() functions is to enforce the user's preference for timer accuracy versus execution time.
SEE ALSO
bintime(9), getbintime(9), getmicrotime(9), getnanotime(9), microtime(9), nanotime(9), tvtohz(9)
AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>.
BSD
July 25, 2013 BSD
Related Man Pages
timercmp(3) - netbsd
timeval(3) - netbsd
bintime(9) - netbsd
getnanotime(9) - netbsd
nanotime(9) - netbsd
Similar Topics in the Unix Linux Community
Working out end time from start + elapsed
elapsed time
Help needed with elapsed time from text values
Doing arithmetic on elapsed times
Calculatin cumulative elapsed time from mm:ss.ss data