freebsd man page for device_get_softc

Query: device_get_softc

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_GET_SOFTC(9)					   BSD Kernel Developer's Manual				       DEVICE_GET_SOFTC(9)

NAME
device_get_softc -- access driver private instance variables
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> void * device_get_softc(device_t dev);
DESCRIPTION
Return the driver-specific software context of dev. The softc is automatically allocated and zeroed when the device is attached. The softc is also initialized and present when a device is probed, but is subject to caveats as described in DEVICE_PROBE(9). The size of the alloca- tion is determined by the device's driver_t information used to define the driver. The softc typically encapsulates the state of this instance of the device. Driver writers are discouraged from using their own softc management mechanisms. Driver writers should not copy such mechanisms found in drivers in the tree that predate this function.
RETURN VALUES
The pointer to the driver-specific instance variable is returned.
SEE ALSO
device(9), DEVICE_PROBE(9), device_set_softc(9), driver(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
January 21, 2015 BSD
Related Man Pages
device_attach(9) - debian
device_probe(9) - freebsd
device_probe(9) - linux
device_get_softc(9) - hpux
device_get_softc(9) - osx
Similar Topics in the Unix Linux Community
Zytouch Driver 20081023 (Default branch)
Zytouch Driver 20081119 (Default branch)
Syntek Semicon DC-1125 Driver: Release 2.0.0