freebsd man page for device_get_flags

Query: device_get_flags

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_GET_FLAGS(9)					   BSD Kernel Developer's Manual				       DEVICE_GET_FLAGS(9)

NAME
device_set_flags, device_get_flags -- manipulate driver flags
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> void device_set_flags(device_t dev, uint32_t flags); uint32_t device_get_flags(device_t dev);
DESCRIPTION
Each device supports a set of driver-dependent flags which are often used to control device behaviour. These flags are read by calling device_get_flags() and written by calling device_set_flags().
SEE ALSO
device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
September 6, 1999 BSD
Related Man Pages
device_is_alive(9) - freebsd
device_unbusy(9) - debian
device_is_attached(9) - freebsd
device_unbusy(9) - freebsd
device_get_state(9) - osx
Similar Topics in the Unix Linux Community
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Is UNIX an open source OS ?
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)