freebsd man page for device_get_children

Query: device_get_children

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVICE_GET_CHILDREN(9)					   BSD Kernel Developer's Manual				    DEVICE_GET_CHILDREN(9)

NAME
device_get_children -- get a list of devices connected to a device
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int device_get_children(device_t dev, device_t **devlistp, int *devcountp);
DESCRIPTION
Retrieve a list of all device instances currently connected to dev and return the list in *devlistp and the count in *devcountp. The memory allocated for the list should be freed using free(*devlistp, M_TEMP). devlistp and devcountp are not changed when an error is returned.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
August 23, 2008 BSD
Related Man Pages
device_is_alive(9) - freebsd
device_busy(9) - debian
device_detach(9) - freebsd
bus_child_present(9) - freebsd
device_detach(9) - osx
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Scripts without shebang
Is UNIX an open source OS ?
UNIX Environment Setup - (Just starting!)