freebsd man page for devclass_get_drivers

Query: devclass_get_drivers

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

DEVCLASS_GET_DRIVERS(9) 				   BSD Kernel Developer's Manual				   DEVCLASS_GET_DRIVERS(9)

NAME
devclass_get_drivers -- get a list of drivers in a devclass
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int devclass_get_drivers(devclass_t dc, driver_t ***listp, int *countp);
DESCRIPTION
Retrieve a list of pointers to all driver instances currently in the devclass and return the list in *listp and the number of drivers in the list in *countp. The memory allocated for the list should be freed using free(*listp, M_TEMP), even if *countp is 0.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
devclass(9), device(9)
AUTHORS
This manual page was written by Nate Lawson.
BSD
May 19, 2005 BSD
Related Man Pages
driver_module(9) - debian
multi_driver_module(9) - debian
devclass(9) - debian
driver(9) - freebsd
devclass(9) - linux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Scripts without shebang
Is UNIX an open source OS ?
Reason for no directory creation date
Controlling user input