freebsd man page for ctassert

Query: ctassert

OS: freebsd

Section: 9

Links: freebsd man pages | All man pages

Forums: Unix Linux Community | Forum Categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CTASSERT(9)						   BSD Kernel Developer's Manual					       CTASSERT(9)

NAME
CTASSERT -- compile time assertion macro
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> CTASSERT(expression);
DESCRIPTION
The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it is false. The CTASSERT() macro is useful for asserting the size or alignment of important data structures and variables during compilation, which would otherwise cause the code to fail at run time.
IMPLEMENTATION NOTES
The CTASSERT() macro should not be used in a header file. It is implemented using a dummy typedef, with a name (based on line number) that may conflict with a CTASSERT() in a source file including that header.
EXAMPLES
Assert that the size of the uuid structure is 16 bytes. CTASSERT(sizeof(struct uuid) == 16);
SEE ALSO
KASSERT(9)
AUTHORS
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
BSD
September 5, 2008 BSD
Related Man Pages
syscall_module(9) - debian
kassertmsg(9) - netbsd
kassert(9) - netbsd
kdassert(9) - netbsd
rounddown(9) - netbsd
Similar Topics in the Unix Linux Community
Is UNIX an open source OS ?
Reason for no directory creation date
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)