freebsd man page for ctassert

Query: ctassert

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CTASSERT(9)						   BSD Kernel Developer's Manual					       CTASSERT(9)

NAME
CTASSERT -- compile time assertion macro
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> CTASSERT(expression);
DESCRIPTION
The CTASSERT() macro evaluates expression at compile time and causes a compiler error if it is false. The CTASSERT() macro is useful for asserting the size or alignment of important data structures and variables during compilation, which would otherwise cause the code to fail at run time.
IMPLEMENTATION NOTES
The CTASSERT() macro should not be used in a header file. It is implemented using a dummy typedef, with a name (based on line number) that may conflict with a CTASSERT() in a source file including that header.
EXAMPLES
Assert that the size of the uuid structure is 16 bytes. CTASSERT(sizeof(struct uuid) == 16);
SEE ALSO
KASSERT(9)
AUTHORS
This manual page was written by Hiten M. Pandya <hmp@FreeBSD.org>.
BSD
September 5, 2008 BSD
Related Man Pages
syscall_module(9) - debian
_diagassert(3) - netbsd
kdassert(9) - netbsd
roundup(9) - netbsd
syscall_module(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
Mac OS X: Based on UNIX - Solid As a Rock
A simple UNIXtime component in Vue.js
UNIX Environment Setup - (Just starting!)