freebsd man page for buf_unlock

Query: buf_unlock

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUF_UNLOCK(9)						   BSD Kernel Developer's Manual					     BUF_UNLOCK(9)

NAME
BUF_UNLOCK -- unlocks a locked buffer
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> void BUF_UNLOCK(struct buf *bp);
DESCRIPTION
The BUF_UNLOCK() function unlocks a buffer that was previously locked with BUF_LOCK() or BUF_TIMELOCK(). Its argument is: bp The buffer to unlock. The buffer must already be locked.
SEE ALSO
buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), lockmgr(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
July 9, 2001 BSD
Related Man Pages
relpbuf(9) - debian
trypbuf(9) - freebsd
vop_vptocnp(9) - freebsd
pbuf(9) - freebsd
vop_vptocnp(9) - centos
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Scripts without shebang
Memory Leaks
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?