Query: buf_timelock
OS: freebsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
BUF_TIMELOCK(9) BSD Kernel Developer's Manual BUF_TIMELOCK(9)NAMEBUF_TIMELOCK -- locks a bufferSYNOPSIS#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> int BUF_TIMELOCK(struct buf *bp, int locktype, char *wmesg, int catch, int timo);DESCRIPTIONThe BUF_TIMELOCK() function locks the given buffer, and limits the amount of time it will sleep to timo and OR's catch into the sleep's pri- ority. wmesg is the wmesg used in the sleep. Its arguments are: bp The buffer to lock. locktype Flags controlling the type of lock. See lockmgr(9) for details. wmesg The wmesg used in any sleeps while acquiring the lock. catch Priority OR'd into the sleep's priority. timo The timeout for any sleeps encountered during the lock.RETURN VALUESA value of 0 is returned on success. See lockmgr(9) for details on non-zero return values.SEE ALSObuf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)AUTHORSThis manual page was written by Chad David <davidc@acns.ab.ca>.BSDJuly 9, 2001 BSD
Related Man Pages |
---|
buf_timelock(9) - debian |
lockdestroy(9) - debian |
lockmgr_args_rw(9) - debian |
lockmgr_args(9) - debian |
lockstatus(9) - debian |
Similar Topics in the Unix Linux Community |
---|
Calling subscript but sleep halts the main script |