freebsd man page for buf_lockinit

Query: buf_lockinit

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUF_LOCKINIT(9) 					   BSD Kernel Developer's Manual					   BUF_LOCKINIT(9)

NAME
BUF_LOCKINIT -- initializes a buffer lock
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/uio.h> #include <sys/bio.h> #include <sys/buf.h> void BUF_LOCKINIT(struct buf *bp);
DESCRIPTION
The BUF_LOCKINIT() macro initializes a buffer lock. Its argument is: bp The buffer whose lock it to be initialized.
SEE ALSO
buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockinit(9), lockmgr(9)
AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>.
BSD
January 6, 2005 BSD
Related Man Pages
uihold(9) - freebsd
trypbuf(9) - debian
uidinfo(9) - debian
uihold(9) - debian
trypbuf(9) - freebsd
Similar Topics in the Unix Linux Community
Unix File Permissions
Scripts without shebang
Memory Leaks
A simple UNIXtime component in Vue.js
Controlling user input